GitLab Path Traversal Vulnerability CVE-2026-85706: Critical Update
- Severity
- HIGH
- Affected component
- gitlab (github-actions)
- Patched version
- 19.1.8 || 19.2.6 || 19.3.2 || nieuwer
GitLab has addressed a critical vulnerability enabling unauthenticated path traversal in the repository commits API. This flaw allowed arbitrary file reading on the system.
What happened
GitLab patched a high-severity vulnerability, tracked as CVE-2026-85706, which allowed unauthenticated users to perform path traversal in the repository commits API. This exploit enabled reading of arbitrary files on the system. CISA has confirmed the vulnerability is being exploited in the wild with public exploit code available. Users of GitLab Community and Enterprise Editions are advised to upgrade immediately.
The vulnerability was first flagged on September 12, 2026, and confirmed two days later. Affected versions include those below 19.1.8, 19.2.6, and 19.3.2. The patched versions are 19.1.8, 19.2.6, and 19.3.2 or newer. It is recommended to upgrade to these versions and review API logs for any suspicious requests involving parameters like file.path. Rotate any exposed credentials if abuse is detected.
What to do about it
- Upgrade to GitLab 19.1.8, 19.2.6, 19.3.2 or newer.
- Review API logs for suspicious requests with parameters like file.path.
- Rotate exposed credentials if any abuse is detected.
- Monitor the primary sources for any further updates or additional mitigation advice.
How 0Day would have caught this
gitlab is anywhere in your dependency tree, the engineers who own the affected repositories get a push alert the moment it is flagged — no manual audit to remember to run.Read how this differs from waiting on a scanner to catch a known advisory, or see the exact, read-only access 0Day needs to do this for an organization.
Frequently asked questions
Am I affected?
You are affected if you are using GitLab versions below 19.1.8, 19.2.6, or 19.3.2.
What should I do right now?
Upgrade to GitLab 19.1.8, 19.2.6, 19.3.2 or newer and review your API logs for suspicious activity.
Has this been exploited in the wild?
Yes, this vulnerability is being actively exploited according to CISA.
Sources
- Rate limits on GitLab.com are changing
- NCSC-2026-0367 [1.00] [H/H] Kwetsbaarheid verholpen in GitLab Community en Enterprise Editions
- [GHSA-2h44-8472-frjj] @zereight/mcp-gitlab Vulnerable to Server-Side Request Forgery
- [GHSA-cv3r-c5h8-f4g5] @zereight/mcp-gitlab: Unauthenticated arbitrary file read via `upload_markdown` enables PAT exfiltration and full account takeover
- [GHSA-vmp7-252j-cwp7] @zereight/mcp-gitlab: DNS rebinding reaches local Streamable HTTP MCP transport
- [GHSA-2h44-8472-frjj] @zereight/mcp-gitlab Vulnerable to Server-Side Request Forgery
- CISA: Hackers now exploit max severity GitLab flaw in attacks
- Maximum Severity GitLab Flaw Puts Supply Chains at Risk